SlideShowPro for Flash
User Guide

(Version 1.8.x)
**Contents**

Introduction .................................................................................................................. 3
Installation ..................................................................................................................... 4
How SlideShowPro for Flash works ........................................................................... 5

**INTERFACE**

Component sizing / Content area .............................................................................. 7
Slideshow content ........................................................................................................ 8
Navigation ..................................................................................................................... 11
Gallery and Albums ..................................................................................................... 15
Media player .................................................................................................................. 19
Captions ......................................................................................................................... 22
Playback ......................................................................................................................... 24
Feedback ........................................................................................................................ 26
Typography ..................................................................................................................... 28

**CONTENT CREATION AND MODIFICATIONS**

Content loading and creation overview ..................................................................... 30
Creating an XML document .......................................................................................... 31
Creating slideshow content: images ............................................................................. 33
Creating slideshow content: videos ............................................................................. 35
Creating thumbnail navigation links and link previews ............................................. 37
Creating album preview images ................................................................................... 39
Creating content captions and hyperlinks ................................................................. 41
Creating watermarks .................................................................................................... 42
Loading album background audio .............................................................................. 43
Loading sound effects .................................................................................................. 44
Enabling full screen mode ............................................................................................ 45
Loading Media RSS feeds ............................................................................................ 46
Loading multiple XML documents ............................................................................. 47

**UPDATING AND TROUBLESHOOTING**

Updating previous versions .......................................................................................... 50
Questions and answers ................................................................................................. 51
Introduction

Thanks for purchasing SlideShowPro for Flash.

This user guide is a complete, top-to-bottom overview of how SlideShowPro for Flash works. The first section, “Interface,” walks you through all the interface elements in SlideShowPro for Flash; covering everything from dimensions to style and the many available options. The second section, “Content Creation and Loading,” provides instructions on how to independently construct an XML file, create slideshow content, and other tasks.

If you’re in a hurry and would like to build a slideshow right now, jump over to the Quick Start PDF included alongside this document. It offers a lightning-fast walkthrough on how to build a slideshow, right now, in just a few minutes.

But if you’re planning on loading a fair amount of content, or visually customizing the component, it’s advised you stay here and follow along to obtain an understanding of how the component operates before taking the time to create content. It’ll pay off - promise!

If you get lost along the way and require assistance, check out our forums at: http://forums.slidehowpro.net. Chances are your question has already been answered by someone else. If all else fails, click the “Contact” link at the bottom of our web site to send a support request email.

Here are the typographical conventions you can expect to see:

Parameter name
Indicates parameter names that are assigned to SlideShowPro for Flash in Flash’s Component Inspector panel. They will also be used (sporadically) for typographical emphasis.

Constant width
Used for samples of XML, JavaScript, ActionScript, and other code.

Constant width italic
A placeholder within code samples that should be substituted with your own value.
Installation

SlideShowPro for Flash is an ActionScript 2.0 component for Macromedia Flash MX 2004, Macromedia Flash 8, and Adobe Flash CS3. It is bundled as a Macromedia/Adobe extension file (MXP) and installed through the standalone Extension Manager application.

To install SlideShowPro for Flash, quit Flash (if it is currently running). Unzip the ZIP file you received after purchasing the component, and open the folder it created. Inside will be a folder named “Extension” containing a file with a “.mxp” extension. Double-click on the MXP file.

If you have Extension Manager installed, the application will launch and walk you through the installation process. If your computer returns an error, stating that it doesn’t know what to do with the file, visit http://www.adobe.com/exchange/en_download/ to download the latest version of Extension Manager. Install Extension Manager, then retry installing the MXP file.

If Flash isn’t one of the available options, quit Extension Manager. Launch Flash, and select “Manage Extensions” from the Help menu. Extension Manager should launch, recognize your installation of Flash, then allow you to install the extension.

When Extension Manager completes, you should see “SlideShowPro for Flash” listed in the Manager interface. You have successfully installed SlideShowPro for Flash, and may now quit Extension Manager.
How SlideShowPro for Flash works

After installation of the extension, (see previous chapter), SlideShowPro for Flash is available in Flash’s “Components” panel, which is opened in Flash MX 2004 by selecting Window > Development Panels > Component Inspector, or Window > Component Inspector in Flash 8 / Flash CS3. To begin creating a slideshow, you drag SlideShowPro for Flash from the Components panel to the Stage of your FLA. This creates an “instance” of SlideShowPro for Flash in your movie.

Note: If you are using Flash CS3, FLAs must be created with “ActionScript 2.0” as the language option. The default “ActionScript 3.0” option will not work with SlideShowPro for Flash.

LIVE PREVIEW

Instances of SlideShowPro for Flash on the Stage are in “Live Preview” mode; a special state for visualizing parameter modifications in real time (see left). Any parameter (with a visual nature) that’s modified in the Component Inspector will be automatically reflected in the instance’s Live Preview. When a SWF is published, you effectively exit Live Preview mode, but the instance of SlideShowPro for Flash contained inside will use all of the parameters you assigned while editing in Live Preview.

COMPONENT INSPECTOR PANEL

The Component Inspector panel (see right) is the user interface for customizing nearly all of SlideShowPro for Flash’s options. Open the panel in Flash MX 2004 by selecting Window > Development Panels > Component Inspector, or Window > Component Inspector in Flash 8 / Flash CS3. Then select the instance of SlideShowPro for Flash on the Stage. The panel will fill, in alphabetical order, with all of the available parameters. You will use this panel many times throughout this guide.

XML

All slideshow content is loaded from outside published SWFs containing instances of SlideShowPro for Flash. The “glue” between the SWF and your content is a separate XML file, which is a simple markup document that tells SlideShowPro for Flash how many images you have and where they are. You may create and load your own XML file, load RSS feeds from Flickr.com, or load content from our content management system SlideShowPro Director.

ONWARD!

That, on a basic level, is how SlideShowPro for Flash works. Next up, an overview of the component’s main interface elements.
Interface
Component sizing / Content area

You may modify SlideShowPro for Flash’s width and height to any size, and all internal elements will automatically reposition themselves. Resizing also plays an important role in how slideshow content is presented. Both of these topics will be covered in this chapter.

RESIZING

To resize SlideShowPro for Flash, click on the instance of the component on the Stage and select Modify > Transform > Scale from the application menu. Little black boxes will appear around the perimeter of the component. Click and hold a corner block, and drag to change the instance’s width and height. For more precise control, open the Properties Panel (Window > Properties) and modify the W: and H: values to any size you need.

STAGE SIZE

While resizing, keep in mind that the Stage of your FLA must be at least the same size as your instance. All new instances are the same size as new FLAs, but if you modify your instance size you may need to modify your Stage size as well. Opening the Properties Panel (Window > Properties) and click on the “Size:” button (shown left) to change if necessary.

CONTENT AREA SIZE

When the instance size changes, you are also changing the dimensions of all internal elements; including the dominant empty space where your slideshow content appears. This empty space is known as the “Content Area.” The Content Area’s dimensions are always displayed in the upper-left hand corner while in Live Preview mode. The first number is the width, which is equal to the width of the instance. The second number is the height, which is equal to the height of the instance minus any inline elements (e.g., the navigation bar and inline captions).

CONTENT AREA STYLE

The following parameters control the color and transparency of the Content Area:

SUMMARY

Now that you have a basic understanding of how instance size affects the Content Area, let’s move on to the next chapter to discuss slideshow content.
**Slideshow content**

SlideShowPro for Flash can load both images and videos and display them in the Content Area (see previous chapter), as well as stream audio from MP3 files for background music or narration. This chapter covers acceptable file formats, scaling, alignment, hyperlinks, preloading, caching, as well as a basic walkthrough on content creation.

**IMAGE FORMATS**

If you publish to Flash Player 7, SlideShowPro for Flash will only load non-progressive JPGs. If Flash Player 8 or higher, SlideShowPro for Flash will load GIFs, JPGs (any type), or PNGs. All images must be 72 dpi. GIF animations are not supported in any player version. SWFs are acceptable, but it’s recommended that you keep animation and interactivity to a minimum. The reason is that SlideShowPro for Flash layers content in order to create transitions, which can obscure button hyperlinks in a loaded SWF.

**VIDEO FORMATS**

Like images, acceptable video formats are also dependent on what version of the Flash Player you publish to. Flash Player 7, 8 and 9 will all load videos encoded in the FLV format. On the very bleeding edge is “Flash Player 9 Update 3” which adds support for videos encoded in H.264, including MP4, M4V, M4A, MOV and 3GP. SlideShowPro for Flash can load these video types, but you should only do so if the majority of your web audience has this player version (or newer). For this reason it is recommended (for now) that videos should always be in FLV format.

**AUDIO FORMATS**

SlideShowPro for Flash accepts MP3 files to use as background audio for any album. The type of MP3 that’s acceptable is dependent on what the Flash Player supports. With that, MP3s must be encoded with a sample rate of 44.1 khz one of the following supported bit rates (kbps): 8 / 16 / 20 / 24 / 32 / 48 / 56 / 64 / 80 / 112 / 128 / 160. Most MP3s meet these criteria, but if your audio plays back fast or slow, it’s been encoded using an unsupported bit rate and/or sample rate.

**CONTENT SCALING**

The width/height of your instance, as well as the Content Area inside, dictates how large or small your content is when loaded. By default, content is loaded and proportionally downscaled (if necessary) to fit the Content Area. This may be modified through the Content Scale parameter in the Component Inspector. Options include “None” (scaling turned off), “Crop to Fit” (proportionally scales content until it fills the Content Area, then cropped), “Crop to Fit All” (just like “Crop to Fit” except it uses the entire area of the instance), “Proportional” (proportionally downscales/upscales content larger and smaller than the Content Area), and “Downscale Only” (proportionally downscales content larger than the Content Area). The following illustration shows their differences (green outline is the Content Area sized horizontally and vertically):

![Crop to Fit](image1.png) ![Proportional](image2.png)
CONTENT ALIGNMENT

If your content is smaller than the Content Area, you may also choose where your image is positioned inside. This is controlled through Content Align. Options include:

An additional formatting option is available when loading content from either SlideShowPro Director, or from a Media RSS feed containing multiple image size options. Named Content Format, this parameter allows you to choose which “view” of SlideShowPro you’d like to load optimized images for. Options include “Normal” (the default) and “Full Screen.” “Normal” means that content will be loaded that’s optimized (both in file size and dimensions) for your in-browser view. “Full Screen” means that content will be loaded that’s optimized for viewing full screen (and are thus much larger both in file size and dimensions). This latter option produces slower image loads in your browser, but higher quality imagery when viewed full screen.

By default, slideshow content is loaded without applying any strokes or padded background around their perimeter. They’re simply loaded as-is. If however you’d like to give each slideshow image and/or video a “framed” look, you may do so through the parameters noted in the left diagram.

Frames use a CSS-like system, whereby you can increase / decrease the amount of “matting” around an image by adjusting a padding attribute. In the case of SlideShowPro for Flash, this is handled by Content Frame Padding, which must be set to a value higher than zero in order to apply a frame color (Content Frame Color) and alpha transparency (Content Frame Alpha).

All slideshow content is invisibly preloaded before it appears. Progress is communicated to the end user through a “Pie” preloading animation in the center of the Content Area. When the animation ends, the requested image will load. More information on preloading can be found in the “Feedback” chapter later on in this User Guide.

SlideShowPro for Flash can cycle through all of the content in an album and invisibly load them into the browser cache. When used, any requested content that has been cached will display immediately without any preloading. Caveats include a slightly longer album startup process, as well as additional
server load. If bandwidth isn't a concern however, it's there for you to use. To turn this feature on, set Cache Content to “Only Thumbnails” to load just the thumbnail images used for link previews and navigation links (more on both of those in the “Navigation” chapter”), “Only Images” to skip videos (if included) or “All” to cache all the content an album contains.
Navigation

The navigation bar at the bottom of SlideShowPro for Flash is where a user controls your slideshow. It can be customized a variety of ways, all of which will be explored in this chapter.

GENERAL OVERVIEW

By default, the navigation bar appears in every slideshow you publish. If you’d rather not include it, set Navigation Appearance to “Hidden” in the Component Inspector. Your slideshow will continue to operate as normal (your users simply won’t have an interface to use). You may also set this to “Hidden When Gallery Open” if you’d rather not show the navigation bar when the gallery opens.

The navigation bar is always the same width as SlideShowPro for Flash, but its height changes according to content it contains. Increasing the height of the navigation bar decreases the size of the Content Area (see “Component Sizing / Content Area” earlier in this guide), and vice versa. So it’s a good idea to style the navigation before creating slideshow imagery.

BACKGROUND COLOR

There are three backgrounds in the navigation bar: a general background, a gradient overlay background, and a radius-corner background. The general background is at the very bottom, the gradient background draws a semi-transparent bevel over the general background, and the radius-corner background is sandwiched between the gradient background and the image links it contains. You can adjust the their style using the above parameters in the Component Inspector.

BUTTONS

The navigation bar contains an embedded set of buttons for content navigation, playback and to engage other functionality. While browsing a slideshow, each playback button will automatically enable/disable when they can/cannot be used. For example, if a user is viewing the first image, both the “Previous Image Group” and “Previous Image” buttons will disable, for it would be impossible to go backward. Advancing to the second image would enable “Previous Image,” and so on.
When disabled, SlideShowPro for Flash makes the buttons semi-transparent to communicate their inactive state. This level of transparency can be modified through Icon Inactive Alpha. Setting this to zero will effectively hide inactive icons from the user.

Lastly, you can control which buttons are available to your users through Navigation Buttons Appearance. You can selectively include / exclude any button, show them all, or hide them all.

Note: All of the buttons can be replaced with your own, or a SlideShowPro for Flash Button Pack. Instructions are available in the SlideShowPro for Flash Customization Guide PDF.

**BUTTON STYLE**

All buttons are styled light-gray by default. Modify Navigation Icon Color to edit their color, as well as Icon Shadow Alpha to control the amount of gradient overlay drawn on top. Icon Shadow Alpha also applies a shadow effect underneath each button.

**IMAGE LINKS**

In the center of the navigation bar is the “navigation link” area. The area fills with as many links as it can display. To increase the number of links, increase the width of SlideShowPro for Flash, or remove some buttons through Navigation Buttons Appearance. To decrease, do the opposite. If the total number of images in your album is greater than the available area, pagination is turned on; enabling the Previous Image Group and Next Image Group buttons.

**IMAGE LINK APPEARANCE**

SlideShowPro for Flash has two built-in types of navigation links: “Numbers” and “Thumbnails.” Both load the slideshow image they correspond to when clicked. You may choose which link type to use through Navigation Link Appearance. The following is an overview of each link type.

**“NUMBERS”**

This displays links to an album’s images using textual numbers. It is the link type SlideShowPro for Flash uses by default. These parameters control its appearance:
The numbers can be any point size, color, or typeface. Modify Navigation Number Link Text Size to alter their point size and Navigation Number Link Text Color to alter their color. To change the typeface used, modify Typeface - General. (Note: For more information on how to customize type, including embedding custom fonts, see the “Typography” chapter in this guide).

During your slideshow, SlideShowPro for Flash will automatically highlight the current image in view by changing the color of its corresponding link. This color is controlled by Navigation Link Current Color (also used to style the first number/thumbnail in the navigation while in Live Preview mode). The color of image numbers change when rolled-over with the mouse pointer. This color is set by Navigation Link Rollover Color.

“THUMBNAI LS”

This displays links to an album’s images using thumbnail images. These parameters control their appearance:

With “Thumbnails,” SlideShowPro for Flash loads separate thumbnail images into containers which are assigned a width and height in the Component Inspector (Navigation Thumbnail Link Size). The containers display images with different dimensions and/or aspect ratios (e.g., landscape and portrait) by proportionally scaling the images to fit, then cropping the center of each photo. This gives all your thumbnail links a uniform appearance.

To change the background color of each thumbnail container, modify Navigation Thumbnail Link Background Color. To change how much background is visible (in pixels) around the images they contain, modify Navigation Thumbnail Link Stroke Width. To control the amount of shadow underneath each thumbnail background, modify Navigation Thumbnail Link Shadow Alpha.

Like the “Numbers” navigation type, SlideShowPro for Flash automatically changes the style of thumbnail links to show which image is currently in view and which is being rolled-over by the mouse pointer. Modify Navigation Link Current Color to control the former and Navigation Link Rollover Color to control the latter.

LINK PREVIEWS

An extra feature you can add to either Navigation Link Appearance are link preview images. These are little windows that contain a separate, smaller version of a slideshow image when an image link in the navigation is rolled over. Link previews only appear if Navigation Link Preview Appearance is set to “Visible” and your XML file contains links to thumbnail imagery. If data doesn’t exist, the link preview won’t display. These parameters control their appearance:
Every link preview contains two parts -- a background, and an inner container for your image to load into. To change the color/transparency of the background (which is white and opaque by default) modify Navigation Link Preview Background Alpha/Color. To change how much background is visible (in pixels) around the image it contains, modify Navigation Link Preview Stroke Weight.

The size of the inner container is set by Navigation Link Preview Size. SlideShowPro for Flash uses these dimensions to determine how to scale (if at all) the preview image it loads. You can control this through Navigation Link Preview Scale. When set to “Proportional” (default), preview images will proportionally downscale or upscale to fit the largest of the two container dimensions. When set to “Crop to Fit,” preview images will proportionally downscale or upscale until they completely fill the entire container area, and are then cropped in the center. Finally, when set to “None,” preview images are loaded without any scaling or size detection.

KEYBOARD NAVIGATION

Your keyboard may be used to control buttons in the navigation when your SWF has focus in the web browser. Focus is enabled by clicking anywhere inside the SWF. This is turned on by default. If you’d rather not give your users this option, you may turn it off by setting Keyboard Control to “Off.” Here are the accepted keys and their function:

F: Enter full screen

G: Open/close gallery

N: Hide/show navigation bar

Left arrow: Load previous content

Up arrow: Skip to next content link group

Right arrow: Load next content

Down arrow: Skip to previous content link group

Space Bar: Pause/auto-play playback
Gallery and Albums

The gallery interface is where all your albums are stored. Like an HTML table, the gallery contains a series of rows and columns and fills the cells with albums. It is opened and closed through the gallery icon at the far left of the navigation bar.

GALLERY SIZE AND LAYOUT

By default, the gallery is created with two columns and four rows. The size of each album cell, in addition to the number of rows and columns the gallery can display, are directly related to the overall width and height of SlideShowPro for Flash. If you increase the size of the instance, the gallery will increase the size of each album cell and maintain the number of assigned rows and columns. If you decrease the size of the instance, the gallery will decrease the size of each album cell until the number of assigned rows and columns can no longer be supported; at which point the number of rows and columns will automatically decrease to give each album cell more space.

To change the gallery layout, modify Gallery Rows and Gallery Columns. If you enter a number that’s too high for the instance to support, it will be ignored and the maximum possible value will be used.

To alter the amount of negative space around and between albums, modify Gallery Padding.

When ordering your albums in the gallery, SlideShowPro for Flash always starts with the first row and column, and (by default) moves from left-to-right filling cells until reaching the end of a row. It then moves to the first column / second row and continues. To change, modify Gallery Order.

GALLERY COLOR

To modify the background color of the gallery, modify Gallery Background Color. You can also change the transparency of the background by modifying Gallery Background Alpha (0 is invisible, 100 is opaque).

GALLERY DISPLAY

By default, the gallery is hidden underneath the navigation and pops open when the gallery button in the navigation is toggled. If however you’d prefer to start your slideshow with the gallery interface, instead of auto-starting with the first album, set Gallery Appearance to “Open at Startup.” To remove the gallery, and thus remove the gallery button from the navigation, set Gallery Appearance to “Hidden.”

GALLERY NAVIGATION

If SlideShowPro cannot fit all of your albums in one gallery screen, your albums will spillover to two
or more screens which can be accessed through the Gallery Navigation. By default the navigation element is always visible, regardless of how many screens exist. If however you plan on only including one screen of content, you may remove the navigation through Gallery Navigation Appearance.

When a screen is available, the previous and next screen buttons enable and change background color from Gallery Navigation Inactive Color to Gallery Navigation Active Color. The background color changes again (to Gallery Navigation Rollover Color) when an enabled button is moused-over.

Here are the parameters that control the style of the Gallery Navigation:

- Gallery Navigation Inactive Color
- Gallery Navigation Active Color
- Gallery Navigation Rollover Color
- Gallery Navigation Text Color
- Gallery Navigation Text Size
- Gallery Navigation Stroke Appearance
- Gallery Navigation Stroke Color

ALBUMS OVERVIEW

By default, each album displays a textual title and description. This data is read from the title and description attributes assigned to each album node in the XML file. Album previews are thumbnail images you can (optionally) add and display in a variety of ways.

ALBUM COLOR, TYPE AND PADDING

The following parameters control the color and size of default album content:

- Album Stroke Appearance
- Album Stroke Color
- Album Title Color, Album Title Size
- Typeface - Headers
- Album Padding
- Album Rollover Color
- Album Description Color, Album Description Size
- Typeface - General
- Album Background Color
- Album Background Alpha

Every album background can be assigned the same color, as well as transparency to partially reveal the gallery color underneath. Albums also provide visual feedback to rollovers through Album
Rollover Color, which temporarily changes the background color of the applicable element.

ALBUM PREVIEWS

Albums can also display a preview image to give viewers a visual sneak-peak into the content an album contains. There are four styles to choose from using the Album Preview Style parameter: “Inline Left,” “Inline Right”, “Banner” and “Fill.”

ALBUM PREVIEW STYLE: “INLINE LEFT” / “INLINE RIGHT”

The default preview style is “Inline Left,” which is demonstrated above. With the “Inline…” styles, you assign the width / height of the previews through Album Preview Size, and your assigned images will proportionally scale to fit these dimensions (if different). You can also crop to fit your images to these dimensions, or not scale the imagery at all using Album Preview Scale.

Inline previews are wrapped with an outer background element for decorative purposes. The color/line thickness can be assigned through Album Preview Stroke Color / Weight. If you’d rather not show the background, set Album Preview Stroke Weight to zero.

ALBUM PREVIEW STYLE: “BANNER”

The “Banner” preview style is very similar to both “Inline” options, with the exception of width and scaling. When created, SlideShowPro for Flash uses the height assigned in Album Preview Size, but ignores the assigned width. Instead, SlideShowPro for Flash calculates how much horizontal space is available and assigns the preview width automatically.
As for scaling, both “Proportional” and “Crop to Fit” options do the same thing; imagery (if not the same size) is scaled to fill the preview, then cropped in the center. If you’d rather not apply any scaling, set Album Preview Scale to “None” and the images will be loaded “as-is.”

**ALBUM PREVIEW STYLE: “FILL”**

The “Fill” style removes the album title, description and preview background and uses the entire surface area of each album to display a preview. “Fill” thus ignores any assigned value in Album Preview Size, and instead calculates the available width and height automatically.

As for scaling, both “Proportional” and “Crop to Fit” options do the same thing; imagery (if not the same size) is scaled to fill the preview, then cropped in the center. If you’d rather not apply any scaling, set Album Preview Scale to “None” and the images will be loaded “as-is.”

For information on how to create album previews for your gallery, see the “Creating album preview images” chapter later in this guide.
Media player

SlideShowPro for Flash includes an integrated media player that appears when a video is loaded, or an album contains background audio. If a video is loaded in an album containing audio, audio playback will shut off and the media player will change to its video playback interface. The player will then revert back to its audio interface, and restart audio, when reaching an image thereafter.

MEDIA PLAYER VISIBILITY

When video or audio is detected, the media player will slide up from the bottom and remain visible for five seconds. The player will then move itself out of the way, but can be brought back anytime by moving the mouse pointer near where the player used to be.

Visibility / position options include Media Player Position (which allows you to place the media player at the top) and Media Player Appearance (which allows you not auto-hide the player, as well as remove it from view altogether).

MEDIA PLAYER SIZE

By default, the media player’s width is equal to the total width of your SlideShowPro for Flash instance minus 20%. To make it wider or narrower, alter Media Player Scale to any value between 0 and 100. The media player’s height is automatically calculated using the height of the play/pause button, as well as the point size of the duration text field at the far right.

VIDEO: COLOR PARAMETERS

![Media player background color](image1)

MEDIA PLAYER BACKGROUND COLOR

MEDIA PLAYER BACKGROUND ALPHA

MEDIA PLAYER ELAPSED BACKGROUND COLOR

MEDIA PLAYER VOLUME HIGHLIGHT COLOR

MEDIA PLAYER ICON COLOR

MEDIA PLAYER PROGRESS COLOR

MEDIA PLAYER BUFFER COLOR

MEDIA PLAYER VOLUME BACKGROUND COLOR

VIDEO: TEXT PARAMETERS

![Media player text color](image2)

MEDIA PLAYER ELAPSED TEXT COLOR, MEDIA PLAYER TEXT SIZE

MEDIA PLAYER TEXT COLOR, MEDIA PLAYER TEXT SIZE
VIDEO: PLAYBACK

Videos playback in SlideShowPro for Flash differently than imagery. Most notably, videos do not adhere to the Transition Pause parameter. SlideShowPro for Flash instead uses the duration of the video itself to decide how long the content should remain view. For that reason, auto-playback (if enabled when a video is loaded) is shut off whenever a video loads.

What happens when a video completes is dependent on how Display Mode is initially set. If set to “Auto,” SlideShowPro for Flash will restart auto-playback and load the next piece of slideshow content in queue. If set to “Manual,” your video will simply stop.

VIDEO: PREVIEW / AUTO-START

By default, video’s automatically start when enough data has been buffered to begin playback. If however you’d prefer to not auto-start, you can turn this off through Video Auto Start. With this set to “Off,” SlideShowPro for Flash will attempt to load a preview graphic associated with the video (through the XML), and display a play button in the center of the video. Clicking the button starts the video and removes the preview. The play button then reappears when reaching the end of a video (if stopped), and restarts the video when clicked.

Note: More information on creating video previews can be found in the “Creating slideshow content: videos” chapter later in this guide.

AUDIO: COLOR PARAMETERS

AUDIO: TEXT PARAMETERS

AUDIO: PLAYBACK

By default, SlideShowPro for Flash will stop playback of your album’s audio when it reaches the end
of the MP3 file. If you would like to change this behavior (so the audio loops back to the beginning every time it finishes), change the Audio Loop property in the Component Inspector to “On.”

The Audio Pause parameter controls whether your audio stops when a user clicks the display mode playback button in the navigation. It is set to “On” by default, which means the audio will stop when slideshow playback stops. Set this to “Off” if you’d rather it continue.

AUDIO: CAPTIONS

When audio is loaded, SlideShowPro for Flash reads the ID3 metadata inside your MP3 file and displays the song title and artist attribution in a text field to the right of the playback button. If you’d rather not display ID3 data, simply add an audio caption for your MP3 in the XML (or through Director’s “Audio” tab in Edit Album). This will override the ID3 data. For instructions on adding audio, see the “Content Loading and Creation” section later in this guide.
Captions

Captions are a great way to enhance your slideshow by providing textual information about your photos. SlideShowPro for Flash offers a variety of caption styles and layouts for you to choose from.

CAPTION OVERVIEW

By default, SlideShowPro for Flash displays image captions as a drop-down overlay originating from the top of the component window. The caption appears when a user rolls over a photo, and retracts when they roll out. It also automatically changes its width to match the size of the photo it corresponds to. Every type of caption is constructed using these two elements:

```
<table>
<thead>
<tr>
<th>CAPTION HEADER</th>
<th>CAPTION TEXT</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image 3 of 146</td>
<td>Image caption for photo 1</td>
</tr>
</tbody>
</table>
```

CAPTION HEADER

The caption header is included, by default, with every caption. The type of data it displays is controlled through Caption Header Appearance. Options include “Image Count,” “Image Title,” “Album Title,” and “File Name.”

“Image Count” displays “Image [image number] of [total album images],” “Image Title” displays the title of an image as assigned in the XML file (more on that a little later), “Album Title” displays the title of the album from which the current image originates, and finally “File Name” displays the file name of the image.

If you’d rather not display the caption header, set Caption Header Appearance to “Hidden.”

CAPTION TEXT

The caption text area displays a text field that is automatically populated with caption data loaded from the XML document. Your captions may be as long as you like. SlideShowPro for Flash will increase the height of the caption text area as you add more text.

CAPTION STYLE

The following parameters control the appearance of captions:

```
<table>
<thead>
<tr>
<th>CAPTION TEXT COLOR, CAPTION TEXT SIZE</th>
</tr>
</thead>
<tbody>
<tr>
<td>CAPTION TEXT ALIGNMENT</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CAPTION BACKGROUND COLOR</th>
</tr>
</thead>
<tbody>
<tr>
<td>CAPTION BACKGROUND ALPHA</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>TYPEFACE - HEADERS</th>
</tr>
</thead>
<tbody>
<tr>
<td>TYPEFACE - GENERAL</td>
</tr>
</tbody>
</table>
```

Image 3 of 146

Image caption for photo 1
Nearly all of the parameters shown above should be pretty straightforward, with the possible exception of **Caption Padding**. This parameter is assigned as an array using the following (CSS-like) order: top, right, bottom, left. These four values are applied around both text fields in the caption area.

**CAPTION TYPES**

SlideShowPro for Flash offers a handful of ways to display captions in your slideshow. These may be assigned through **Caption Appearance**. Options include:

“Never”: Caption area never appears.

“Inline”: Captions are displayed inline below the Content Area and above the navigation in a static area that spans the width of the component window.

“Overlay Mouse Over”: (Default) Caption area enters the component as a layer when the user rolls their mouse pointer over slideshow content, then disappears when they roll-out. Area spans the width of the content it is assigned to.

“Overlay Mouse Over (If Available)”: Same as “Overlay Mouse Over” except SlideShowPro for Flash will first test for the existence of a caption. If none exists, caption will not be displayed.

“Overlay Auto”: Same as “Overlay Mouse Over,” except no interaction is required. Caption automatically appears.

“Overlay Auto (If Available)”: Same as “Overlay Auto” except SlideShowPro for Flash will first test for the existence of a caption. If none exists, caption area will not be displayed.

---

Note: Using an “Inline” caption type will decrease the vertical height of the Content Area by an amount equal to how many rows are in your caption. If you plan on formatting your photos for a “perfect fit” without image scaling, it’s best to either not use this option for if your captions have variable character lengths the Content Area will dynamically change size throughout your slideshow.

---

**CAPTION POSITION**

Any of the aforementioned types can be positioned at either the top or bottom of SlideShowPro for Flash. By default captions are positioned at the top, but you can change this to “Bottom” through **Caption Position**.
**Playback**

SlideShowPro for Flash can pause, play, restart, stop, and loop your slideshow images. This chapter will explain how playback works, as well as the parameters available for modification.

**PLAYBACK OVERVIEW**

On startup, SlideShowPro for Flash automatically loads the first asset in the first album. If the asset is an image, it will “hold” for four seconds before the next asset in queue is loaded and a cross-fade transition effect is applied. At any point during the slideshow a viewer can stop auto-playback by either clicking on the pause button or a link in the navigation. They can then continue to browse content manually, or restart auto-playback by clicking the play button.

Auto and manual playback are controlled through **Display Mode**. It is set to “Auto” by default. If you’d rather start your slideshow in manual mode, set it to “Manual.” SlideShowPro will load the first asset and stop. The viewer will then be able to start auto-playback on their own.

**TRANSITION PAUSE**

While in auto-playback, the viewer is given a configurable amount of time to view an image before SlideShowPro begins loading the next. This stretch of time is assigned through **Transition Pause**. As noted in the earlier Media Player chapter, this interval only applies to images (not videos).

**TIP: TRANSITION PAUSE OVERRIDE**

The **Transition Pause** parameter applies the same amount of time to every image in your gallery. But what if you’d like to display one image for 3 seconds, and another for 5? You can do that by modifying your XML file to include **pause** attributes, like so:

```
<img src="tree.jpg" pause="10" />
```

SlideShowPro for Flash will now stop for 10 seconds after loading the tree photo. You can mix images with and without pause in the XML. Any image that does not have an XML override will use **Transition Pause**.

**TRANSITION STYLE/DIRECTION**

In both auto and manual display modes, a transition effect is applied when switching content. You can control the style of transition used through **Transition Style**, which includes “Blur”, “Cross Fade” (Default), “Complete Fade”, “Dissolve”, “Drop”, “Lens”, “Photo Flash”, “Push”, “Wipe”, and “Wipe to Background”. If you’d rather not have any transition, set it to “None.” The direction of “Wipe”, “Push” and “Dissolve” are set through **Transition Direction**.

Note: The “Blur” and “Dissolve” transitions are only compatible with Flash 8 or higher.

**AUTO FINISH**

If SlideShowPro for Flash is in auto-playback mode when reaching the end of an album, it will
automatically load the first asset of the next album in queue. If another album is not available, it will stop. This behavior is controlled through the Auto Finish Mode parameter. The default option is “Switch,” which loads the next album. Additional options include “Restart,” which will re-load the first asset in the current album, “Stop” which stops auto-playback, and “Open Gallery” which pops open the gallery so the user can select the album they’d prefer to continue with.

**CONTENT ORDER**

As noted earlier, slideshow content is auto-loaded in sequential order. This is set through the Content Order parameter, which is set to “Sequential” by default. When switched to “Random,” SlideShowPro for Flash keeps your content links in the order in which they’re included in the XML, but instead of auto-loading the next content in line it picks content at random from anywhere in the current album. No images or videos are loaded twice, and Auto Finish Mode works just the same.
Feedback

SlideShowPro for Flash displays two “feedback” graphical elements that visually communicate invisible events occurring in the background. These include a preload animation and a timer element that visualizes changes in display mode as well as transition pause countdowns.

**PRELOADER**

Whenever SlideShowPro for Flash loads data, whether it be your XML file, an image or a video, a preloader will appear in the center of the Content Area. The animation will display how much time is left until the asset in question will be completely loaded; thus giving viewers an idea of how long they’ll have to wait. When the asset has completely loaded, the preloader disappears.

There are three preloader animation styles for you to choose from (left to right below): “Bar,” “Pie Spinner,” “Pie” (default), “Spinner” and “Line.” These may be chosen through Feedback Preloader Appearance. If you’d rather not show preloaders in your slideshow, select “Hidden.” The following parameters control the visual appearance of each preloader type.

**TIMER**

SlideShowPro for Flash confirms display mode changes, as well as transition pause wait-time, through the “timer” element that appears/disappears when applicable in the upper-right hand corner. The following parameters control its color and transparency.

To remove the timer element from your slideshow, set Feedback Timer Appearance to “Hidden.”

**VIDEO PLAY BUTTON**

If you choose to load video in your slideshow a play button will appear over your video when necessary. It appears at the beginning of a video to start playback when Video Auto Start is set to “Off,” as well as at the end to restart a video if Display Mode is set to “Manual.”
FEEDBACK SCALE

The size of the preloader, timer and video play button are controlled through Feedback Scale, with each element using a relative percentage of that value. When scaling the elements, the preloader uses 100%, timer 70%, and the video play button 80% of Feedback Scale. This way you can scale the feedback elements up and down and their relative size to one another remains consistent. The default value of 100 is the recommended scale, but if you want larger feedback elements — for example, twice as large — set Feedback Scale to 200.

FEEDBACK POSITION

By default, the preloader appears in the center of the Content Area while the timer appears in the top right. To change this, first choose whether you want the preloader and/or timer inside the Content Area or inside content (Feedback Preloader Position / Feedback Timer Position), then choose one of nine alignment options through Feedback Preloader Align / Feedback Timer Align. The video play button is always in the center of a video, and cannot be changed.
Typography

There are two types of text fields in SlideShowPro for Flash — General, and Headers. SlideShowPro for Flash allows you to use any “system” or custom typeface for these fields.

**SYSTEM AND NON-SYSTEM TYPEFACES**

Type families are assigned through **Typeface - General** and **Typeface - Headers**. By default, both are assigned typeface families that are universally available on end-user’s computers. SlideShowPro for Flash will use whichever typeface in the descending, comma-separated list of font names it finds first.

For a more stylized look, you may embed two non-system typefaces. You would choose this option if you wanted to use bitmap fonts, or a unique TrueType / PostScript font.

---

**Note:** You cannot mix text field types in SlideShowPro. Both the General and Header font must be either system or embedded, but not both.

---

**HOW TO EMBED A NON-SYSTEM FACE**

**STEP ONE: IMPORT FONT INTO LIBRARY**

Open the Library panel (Window > Library). Click the button in the upper-right corner to open the options menu. Select “New Font”. A new window named “Font Symbol Properties” will appear. Click the double-arrow button to the right of the “Font:” field. Select the name of the font. Then give your font a name in the “Name:” field. Leave all other options alone. Click OK.

**STEP TWO: SETUP LINKAGE**

Right-click on the font in the Library and select “Linkage...” from the contextual menu. The “Linkage Properties” dialog will appear (see right). Toggle on the “Export for ActionScript” button, and the “Identifier:” field will fill with the name of your font. “Export in first frame” will also be automatically selected — leave this on. Click OK.

**STEP THREE: MODIFY PARAMETERS**

With your instance of SlideShowPro for Flash selected on the Stage, open the Component Inspector and enter the name of your font into either the **Typeface - General** or **Typeface - Headers** text fields. Then set **Typeface Embed** to True. If you want to use the same face for all text fields, simply re-enter the linkage name in the applicable typeface field.

**STEP FOUR: PUBLISH**

You’re done! Publish a new movie, and your custom typefaces should appear in SlideShowPro for Flash.
Content creation and modifications
Content loading and creation overview

By now you should have a good understanding of how SlideShowPro for Flash works; including Live Preview mode, the Content Area, how in-line elements like the Navigation can alter the internal dimensions of the component, and so on. Now it’s time to get our hands dirty and create some content for SlideShowPro for Flash to load.

USING SLIDESHOWPRO DIRECTOR?

Before we do, there’s one last bit of business. If you have purchased our CMS product SlideShowPro Director, you can skip nearly this entire section. Director was built to supply SlideShowPro for Flash with all the content it requires; regardless of what size you scale the component to or what options you select.

If you aren’t using Director, this section is for you!

Note: The one chapter Director users should read if they want to manage/load video is “Creating slideshow content: videos” section, for Director doesn’t convert or format video files. You will need to create your own FLVs using the instructions in that chapter and upload them to Director.
Creating an XML document

This chapter will explain how to create your own XML document for SlideShowPro for Flash to load. It will address the core elements a slideshow needs in order to operate, as well as options for linking to content. Further chapters in this section will build upon these examples.

DEFAULT XML MARKUP

To create your own XML file, you must use a HTML/ASCII text editor like Dreamweaver, Notepad, TextWrangler, TextMate, etc. Do not use a word processor or rich text editor like Microsoft Word (Windows or OS X) or TextEdit (OS X).

This is the XML markup SlideShowPro requires, at a minimum, in order to work:

```xml
<?xml version="1.0" encoding="UTF-8"?>
<gallery>
  <album>
    <img src="ContentURL" />
  </album>
</gallery>
```

**ContentURL** may be an absolute or relative path to the content you wish to load. To add absolute paths to slideshow content, modify **src** like so:

```xml
<?xml version="1.0" encoding="UTF-8"?>
<gallery>
  <album>
    <img src="http://www.domain.com/path/to/my/image.jpg" />
  </album>
</gallery>
```

For relative paths, and lighter XML markup, you can use a special **lgpath** constructor. Simply add **lgpath** to the **album** element and fill it with the absolute path to the folder containing that album’s slideshow content. You can then modify each **src** value to only include a file name, like so:

```xml
<?xml version="1.0" encoding="UTF-8"?>
<gallery>
  <album lgpath="http://www.domain.com/path/to/my/"
    src="image.jpg" />
</album>
</gallery>
```

If you’d like to keep all content relative so that it can work locally as well as online, you can use a relative path for **lgpath**. The path should be relative to the HTML document embedding the SWF you publish (which by default is in the same directory). Here’s the above example revised with relative paths:

```xml
<?xml version="1.0" encoding="UTF-8"?>
<gallery>
  <album lgpath="path/to/my/"
    src="image.jpg" />
</album>
</gallery>
```
In both examples, SlideShowPro for Flash will take the value of `filepath` and append the value of `src` to form a complete link to each piece of slideshow content.

**XML FILE PATH**

SlideShowPro for Flash automatically looks for XML files you create in the same folder as your SWF. It expects the file to be named “images.xml,” but it doesn’t have to be. Nor does the XML file need to be in the same folder, or even on the same server. You can change SlideShowPro for Flash’s XML File Path to a relative or absolute URL.

Note: If you plan on loading XML data from a different domain than the one that will contain your SWF, read the “Load XML data from a different domain” section of the *SlideShowPro for Flash Customization Guide*.

**SUMMARY**

The preceding examples will be seen again in the upcoming chapters as we add optional features like thumbnails, hyperlinks and captions. But before we get to that, let’s walk through the process of creating imagery for your slideshow.
Creating slideshow content: images

This chapter assumes you intend to create optimized imagery formatted to fit SlideShowPro for Flash’s Content Area (and not use scaling). This assumption is important, for you don't have to create a duplicate set of content. You may load any existing image or video (of an acceptable format) and it will be proportionally downscaled (if necessary) to fit the Content Area. While convenient and time-saving, using existing content not formatted for SlideShowPro for Flash means larger file sizes for your users to load. There will also be some loss of image quality and sharpness by allowing SlideShowPro for Flash to forcibly scale your content. For that reason it is recommended (if you are particular about image quality) to create new, web-optimized tted to fit SlideShowPro for Flash’s Content Area.

Before starting, make sure you have resized your SlideShowPro for Flash instance to the size you need, and that you’ve styled the in-line elements the way you want them to appear. This way you have a fixed Content Area width and height to work with. With all that in place, let’s edit some images.

You’ll need an image editing software application like Adobe Photoshop. Just about any image editor will do, but because Photoshop is the industry standard we’ll be using it here.

**STEP ONE: CHECK CONTENT AREA SIZE, TURN OFF CONTENT SCALE**

Before launching Photoshop, check the “Content Area” dimensions in the upper-left-hand corner of SlideShowPro for Flash’s Live Preview. First number is the width, second is the height. These are your target dimensions. Next, open the Component Inspector and set Content Scale to “None.” This instructs SlideShowPro for Flash to leave your content alone and not perform any scaling.

**STEP TWO: CREATE FOLDER FOR CONTENT**

Wherever you plan on loading your slideshow content with absolute or relative links from the XML file (see previous chapter), create a new folder to contain the images we’re about to create. For the purposes of this walkthrough, we’ll use relative paths by creating a “gallery” folder alongside our FLA, filling it with our first album (“album1”), and then creating a “large” folder inside for our new images. (See right screenshot for an example).

**STEP TWO: EDIT IMAGE IN PHOTOSHOP**

Launch Photoshop and open the original photo you want to edit. Select Image > Image Size from the application menu. A dialog will appear (see left) that displays the width, height and resolution of the image you have opened. First set “Resolution” to 72. Next, using the Content Area dimensions from SlideShowPro, enter whichever value is the largest into the applicable field. The smaller dimension will automatically update so that your image is proportionally downscaled. When complete, make sure that “Resample Image” is selected, and that “Bicubic Sharper” is chosen in the drop-down. Click OK. Your image will resize to your new dimensions.
STEP THREE: SAVE AND LINK

Select File > Save for Web and Devices from Photoshop’s application menu. A new window will appear. In the right, select JPG as your image format, then experiment with Quality to find an acceptable compression level. When complete click “Save.” Save the photo to the folder you created in Step One (which in our example would be gallery > album > large). Then simply edit your XML document so that it links to the new image, like so (if you are using relative paths):

```xml
<?xml version="1.0" encoding="UTF-8"?>
<gallery>
  <album lgpath="gallery/album1/large/">
    <img src="image.jpg" />
  </album>
</gallery>
```

That’s it! Simply repeat this process for each image you want to display.
Creating slideshow content: videos

In this walkthrough we'll create an FLV for SlideShowPro for Flash to load using the Flash Video Exporter application that ships with Flash 8 and Flash CS3. You may use a third party encoder, but the encoder must embed metadata in the FLVS it creates. This is required.

STEP ONE: CHECK CONTENT AREA SIZE, TURN OFF CONTENT SCALE

See “Step One” in the previous section (“Creating Content: Images”).

STEP TWO: CREATE FLV

Open Adobe Flash CS3 Video Encoder. Drag the video you’d like to convert into the large, empty white area. If you’d like to encode more than one, and you’re okay with processing each video using the same quality / size settings, drag more videos into this space as well. This will create a queue for the encoder to work on.

When complete, click on the “Settings” button in the right column. There are a lot of options in the Settings window, so we’ll stick to the basics. First, select an encoding profile in the “Profiles” tab. For general web audiences, “Flash 8 - Medium Quality (400kbps)” is acceptable. Next click on the “Crop and Resize” tab. In the middle of the panel (shown right) is a “Resize” option with inputs for “Width” and “Height.” The default values are the original dimensions of your movie.

Next, using the Content Area dimensions from SlideShowPro for Flash, enter whichever value is the largest into the applicable field. The smaller dimension will automatically update so that your video is proportionally downscaled. For example, if the Content Area displays “483 px / 373px,” enter “483” into the “Width” field. The “Height” value will automatically be calculated so that your original aspect ratio is maintained. When finished, click “OK.”

Finally, click the “Start Queue” button on the right-side of the Video Encoder. After a few minutes, an FLV will be created alongside your original video.

STEP THREE: MOVE FLV AND EDIT XML

Now that you have an FLV, move the video to the directory you’re building your slideshow content in. Then open the XML file that SlideShowPro loads and enter the path to your video as an img element. (See the “How SlideShowPro for Flash works” chapter for more information about XML and directories). For example:

```xml
<img src="video.flv" />
```

STEP FOUR (OPTIONAL): CREATE PREVIEW GRAPHIC

As outlined in the earlier “Media Player” chapter, your video will load and auto-start when viewed. If you would rather not auto-start, you have the option of displaying a preview graphic for your video...
that appears in front of the video when loaded. You don’t have to create a preview, but if you’d like to using a keyframe of your video, here’s how.

First, open in the free QuickTime Player (http://apple.com/quicktime/) the video you used to create the FLV. Move the scrubber to the keyframe you’d like to use. When done, select File > Export from the top menu. A window titled “Save exported file as...” will appear. At the bottom, select “Movie to Picture” for “Export.” If you’d like to adjust compression or format, click the “Options” button. When complete, change the file format in the “Save As:” area at the top to “.jpg”

If your source video is the same dimensions as the FLV you exported, you can simply use the JPG you exported from the QuickTime Player. If different, you will need to open the JPG in Photoshop and resize / format the image to the FLV’s dimensions.

When your video file is complete, move the JPG to the same directory you moved the FLV to, and edit the XML file with either a relative or absolute URL in a “vidpreview” attribute, like so:

```xml
<img src="video.flv" vidpreview="relative/path/to/vidpreview.jpg" />
```

...or...

```xml
<img src="video.flv" vidpreview="http://mydomain.com/vidpreview.jpg" />
```

**STEP FIVE: PUBLISH**

Publish a new movie from Flash, and your video should load / playback in SlideShowPro for Flash!
Creating thumbnail navigation links and link previews

A separate batch of images is required for thumbnail links and previews. If you are just using the SlideShowPro for Flash component without SlideShowPro Director, and are manually creating the content it loads, you need to create smaller, optimized copies of your slideshow images in order to use either of these navigation options.

Before you start creating images though, two decisions need to be made. One, will you use both thumbnail links and previews? Or just one of the two? Second (and depending on what you picked in decision one), are their default widths and heights acceptable?

If you decide to just use thumbnail links (without previews), you should use Navigation Thumbnail Link Size as target dimensions when creating your images. If you want to use both thumbnail links and previews, you should use the Navigation Link Preview Size values (assuming of course the previews are larger, which they almost always are). The reason for making this distinction is that thumbnail previews and navigation links use the same batch of images. So by creating your imagery using the largest dimension, you’ll have better image quality results when downscaled for the smaller one.

**STEP ONE: CREATE A NEW DIRECTORY**

To add thumbnails to your slideshow, create a new folder in the directory you’re building your slideshow in. For the purposes of this walkthrough, we’ll create a folder named “thumbs” inside our “album” folder (see left).

**STEP TWO: CREATE IMAGES**

Open each of the images used for slideshow content in an image editing application (like Photoshop), reduce each of their dimensions to the width and height you need, or crop a particular part of the subject if you’re feeling creative.

**STEP THREE: SAVE IMAGES**

When done, save the thumbnails to the “thumbs” directory you just created. Name them anything you’d like, though if you are creating thumbnails for slideshow content containing only imagery (no video), you can save the thumbs using the same file name as the “large” version they relate to. More on how we take advantage of this shortcut in the next step.

**STEP FOUR: EDIT XML**

With your thumbnails saved, open the “images.xml” document. Depending on whether you’re using relative or absolute paths in your XML document (see the earlier “Creating an XML document” chapter for an overview), add a `tnpath` attribute and enter the path to your “thumbs” folder, like so:

```
<album title="Nature" description="Images of trees, lakes and flowers"

  lgpath="gallery/album1/large/"

  tnpah="gallery/album1/thumbs/">
```

...or...

Figure: New “thumbs” folder added with smaller versions of “large” slide-show content.
<album title="Nature" description="Images of trees, lakes and flowers"
        lgpath="http://www.domain.com/path/to/large/"
        tnpath="http://www.domain.com/path/to/thumbs/">

If in Step 3 above you named your thumbnails with the same file names as their larger counterparts, that's all you need to do! SlideShowPro for Flash will use the src attribute in each img element when looking for your thumbs.

If however you named your thumbnails with different file names, or are loading video (which can't re-use the src value, since it's a video and not an image), then we need to add each thumb's file name to each img element, like so:

```html
<img src="tree.jpg" tn="tree_tn.jpg" />
```

...or when used with video...

```html
<img src="tree.flv" tn="tree_tn.jpg" />
```

Finally, as a last option, if your thumbnails are spread across multiple directories (and not all together in a “thumbs” folder for tnpath to use), you can remove tnpath and link to each thumb with an absolute link, like so:

```html
<img src="tree.jpg" tn="http://www.mydomain.com/tree_tnt.jpg" />
```

**STEP FIVE: PUBLISH**

Publish a movie, roll-over either the numbers or the thumbnails in the navigation, and your thumbnails will appear.
Creating album preview images

Like navigation thumbnail links and link previews (see previous chapter), album previews are separate images assigned through the XML file. This walkthrough will show you how to setup albums to load album previews, as well as instructions for modifying your XML file.

STEP ONE: SHOW THE GALLERY

First, display the gallery in SlideShowPro’s live preview by setting Gallery Appearance to “Open at Startup.” This makes the gallery visible so we can see what we’re modifying in the next step.

Note: Leaving this setting at “Open at Startup” will cause SlideShowPro for Flash, when published, to start with the gallery interface open. If you’d rather auto-start with the first album (the default behavior), change it back to “Closed at Startup” when finished with this walkthrough.

STEP TWO: CHOOSE STYLE

Next, choose which style of preview you’d like to display (options shown in the “Albums” chapter earlier in this Guide) through Album Preview Style. The preview container will update to show your changes, including a dimension readout (see right).

If you choose one of the “Inline” options, modify the width/height of the preview to your liking with Album Preview Size (first number is width, second is height). If you choose “Banner,” the width is automatically calculated for you, but you can modify the height in Album Preview Size. Finally, if you select “Fill,” both the width and height are calculated automatically (and Album Preview Size is ignored).

STEP THREE: CHOOSE SCALE

Album Preview Scale dictates how your images are handled if they are not the same size as the preview container. The default setting is “Proportional,” which means that your images will be proportionally scaled to the preview container’s dimensions.

In the case of both “Inline” styles, a “Proportional” scale will scale the image to the largest dimension possible without cropping. In the case of both “Banner” and “Fill” styles, “Proportional” scaling is the same as “Crop to Fit” scaling, in that the image is proportionally scaled until it fills the container, then cropped in the center.

If you would like to apply no scaling or image size detection at all, set Album Preview Scale to “None.” Your images will be loaded “as is.”

STEP THREE: CREATE PREVIEW IMAGES

You may either use an existing photo (and let SlideShowPro for Flash scale it for you) or you may use an image editor (like Photoshop) and scale and/or crop an image to match the dimensions shown in the live preview.

When your album preview image is ready, save a web-optimized copy of it to your album’s folder. For
the purposes of this walkthrough, we’ll save “albumThumb.jpg” to the root of our first album.

**STEP FOUR: EDIT THE XML DOCUMENT**

Open the XML document SlideShowPro for Flash is loading, and add a `tn` attribute to the album you created the preview for, and assign a relative link to the image. Your XML should now look similar to this:

```xml
<album title="Nature" description="Images of trees, lakes and flowers" 
      lgpath="gallery/album1/large/" 
      tnpath="gallery/album1/thumbs/" 
      tn="gallery/album1/albumThumb.jpg">
```

**STEP FIVE: PUBLISH**

Publish a movie (File>Publish Preview>Flash) and your album preview should now appear!
Creating content captions and hyperlinks

Content captions and hyperlinks are assigned as attributes in your XML file.

CONTENT CAPTIONS

STEP ONE: CHOOSE A CAPTION TYPE

If you haven’t already, choose a caption type through Caption Appearance and style the caption area however you like. The live preview of SlideShowPro for Flash will update to show your setting. (See the “Captions” section earlier in this guide for an overview of available options).

STEP TWO: EDIT THE XML DOCUMENT

Adding caption attributes to each img element in your XML file, like so:

```xml
<img src="tree.jpg" caption="A redwood tree from California" />
```

If you are using the “Image Title” Caption Header Appearance, you will need to add titles to each img element, like so:

```xml
<img src="tree.jpg" caption="A redwood tree from California" title="Tree title"/>
```

STEP THREE: PUBLISH

Publish a new movie. Your captions will now appear using all the options you chose above. If you are using one of the “...(If Available)” caption types, remember that you need to roll-over a photo after it has fully transitioned in order for the caption to appear.

CONTENT HYPERLINKS

STEP ONE: EDIT THE XML DOCUMENT

Open your XML document, and add link attributes containing the URLs you wish to assign, like so:

```xml
<img src="tree.jpg" link="relative/path/to/URL" />
```

When content is clicked, link will be loaded in a new browser window. If you’d like to load your links in the current browser window, or in specific frame, add a target attribute:

```xml
<img src="tree.jpg" link="http://www.trees.com/" target="_self"/>
```

You can also use JavaScript for hyperlinks. For example, this creates a pop-up window:

```xml
<img src="tree.jpg" link="javascript:NewWindow=window.open('http://www.trees.com/','myWindow','width=300,height=300');NewWindow.focus(); void(0);"/>
```
Creating watermarks

Watermarks are graphical assets layered on top of content to deter copying. They are typically semi-transparent and consist of a company logo, a photographer’s name, or a copyright symbol. SlideShowPro for Flash supports watermarks by attaching a Movie Clip created by the developer, layering it above each piece of slideshow content, and positioning it in one of five locations. To add a watermark to your slideshow, follow these steps.

**STEP ONE: CREATE A MOVIE CLIP**

In the FLA containing SlideShowPro for Flash, create an empty Movie Clip by clicking on the plus (+) symbol at the bottom left of the Library (Window > Library). Name it “watermark,” make sure that “Movie clip” is the Behavior, and then toggle on the “Export for ActionScript” option next to “Linkage.” The “Identifier” field should pre-fill with the linkage ID “watermark.” When complete click “OK.” Your movie clip will be created, and automatically opened.

**STEP TWO: CREATE WATERMARK**

Fill the Movie clip with your watermark content. You may create it in Flash using vector shapes and/or type, or for fancier effects, create a semi-transparent bitmap in another software package like Photoshop or Fireworks, export the artwork as a 24-bit transparent PNG, then import it into your Movie Clip.

When your watermark content is complete, select all (Edit > Select All), and then open the Align palette (Window > Design Panels > Align). Ensure that the “To stage:” button is depressed, then click both Align Horizontal and Align Vertical (see right Figure). Your artwork should now be centered both vertically and horizontally inside your Movie Clip. Aligning your artwork in this manner is required in order for SlideShowPro for Flash to accurately position the Movie Clip on top of your slideshow content.

**STEP THREE: ASSIGN WATERMARK TO SLIDESHOWPRO**

Select your instance of SlideShowPro for Flash on the Stage and open the Component Inspector. In the empty field next to Content Watermark, enter the linkage ID for your Movie Clip, which in this case would be “watermark” (without quotes). Next, toggle open Content Watermark Align and choose an alignment position.

**STEP FOUR: PUBLISH**

Publish a new SWF, and your watermark should be appearing on top of your loaded images in the position you chose. The position of the watermark will automatically change each time a new image is loaded so that it always covers your photos (regardless of dimension).
Loading album background audio

This walkthrough will show how to load an MP3 file to use as the background audio for any album in your slide show. For more information on acceptable audio formats, see the “Slideshow content” chapter earlier in this guide. For information on how audio is presented, see the “Media player” chapter.

STEP ONE: CREATE AN AUDIO DIRECTORY

Navigate to the folder where your slideshow files are contained. Create a new folder named “mp3” inside the album you want the audio played with. Place your MP3 file in this directory.

STEP TWO: ADD AUDIO TO THE XML DOCUMENT

The next step is to open your XML document and add an audio attribute to the album element you want audio with. For example:

<album title="Nature" description="Images of trees, lakes and flowers"
  lgPath="gallery/album1/large/"
  audio="gallery/album1/mp3/audio.mp3">

STEP THREE (OPTIONAL): ADD AN AUDIO CAPTION

By default, SlideShowPro for Flash will read the ID3 metadata in your MP3 file and display the song title and artist in the media player. If you’d like to override this, simply add an audioCaption attribute to the same album edited earlier, and fill it with your text. Your revised XML document would then look like this:

<album title="Nature" description="Images of trees, lakes and flowers"
  lgPath="gallery/album1/large/"
  audio="gallery/album1/mp3/audio.mp3"
  audioCaption="Talking Heads - Nothing but Flowers">

Note: Flash Player 7 and later supports ID3 1.0, ID3 1.1, ID3 2.3 and ID3 2.4. If no metadata appears, you can convert your MP3 file’s ID3 tags to a supported version in iTunes by right-clicking on an MP3, selecting “Convert ID3 tags...”, and choosing one of the aforementioned versions.

STEP FOUR: PUBLISH

You’re done! Now whenever a user loads the “Nature” album the audio player will appear, it will automatically stream the Talking Heads song.
Loading sound effects

SlideShowPro for Flash supports the playback of sound effects, and offers three types of interactive events you may attach sounds clips to.

Sound effects are assigned through Sound Effects in the Component Inspector. The parameter accepts an array containing the Library linkage IDs of the sound files you’d like to use.

The sound clip in the first array position is played when a user clicks on an image number, the next/previous image buttons, the open/close gallery button, the auto-play/pause button, or an album in the gallery. The sound clip in the second array position is played when a user rolls their mouse pointer over an image number, an album in the gallery, or the next/previous screen gallery buttons. And finally, the sound clip in the third array position is played when a user clicks on the next image group/previous image group buttons, or the next/previous screen gallery buttons.

Here’s how to load audio clips as sound effects in your slideshow.

**STEP ONE: IMPORT SOUND FILE INTO LIBRARY**

In Flash, select “File > Import > Import to Library”, and a Finder/Explorer window will open. Navigate to the location of the sound clip (WAV, AIFF, MP3) you wish to use, then click “Import to Library”.

**STEP TWO: SETUP LINKAGE**

Right-click on your sound clip in the library, select “Linkage...” The Linkage Properties window will open. Activate “Export for ActionScript”, and give the audio file a short “Identifier” name. Repeat process for other sound files. When complete, click on the default “[None,None,None]” value assigned to Sound Effects in the Component Inspector. Insert the linkage IDs where appropriate.

**STEP THREE: SET AUDIO QUALITY**

Be sure to optimize your audio before publishing. You can do this globally (same quality for all sound effects) by selecting “File > Publish Settings”, clicking the “Flash” tab, and choosing quality levels for Audio streams and Audio events. Or if you’d like to set quality levels for your clips individually, right click on a sound file in the Library, select “Properties,” and change the settings to your liking.

---

Tip: The lower the bit-rate, the smaller your SWF will be. So try to find a good balance between file size and sound quality.

---

**STEP FOUR: SET VOLUME**

Once your sound effects are playing you may need to adjust their volume. If so, change the numerical value of the Audio Volume to any number between 0 and 100. This value is shared by all sound effects.

**STEP FIVE: PUBLISH**

That’s it! Publish a new movie and your sound effects should playback.
Enabling full screen mode

Flash Player 9 includes the ability to upscale your SWF to completely fill your monitor's screen. Because only Flash Player 9 (and up) supports this feature, SlideShowPro for Flash's full screen button (see the “Navigation” chapter earlier in this guide) only appears if your users have a supported player version installed in their web browser. This automatically overrides any setting you may have chosen in Navigation Buttons Appearance that includes the full screen button, for without Flash Player 9 the button wouldn't function.

Unfortunately, full screen mode is not enabled by default when publishing a SWF from Flash. Depending on the type of Flash you have will dictate how you go about turning it on. Here's how.

**STEP ONE: MODIFY STAGE ALIGNMENT AND SCALE**

First create a new timeline layer in your FLA. Select the first empty keyframe in that new layer. Open the Actions Panel (Windows > Actions). Enter the following into the panel window:

```javascript
Stage.align="TL";
Stage.scaleMode="noScale";
```

These two values will instruct Flash to always align the SWF's Stage in the top-left corner, and to not scale the contents contained therein.

**STEP TWO: ENABLE FULL SCREEN MODE**

If you are using Adobe Flash CS3, open File > Publish Settings and click on the HTML tab. In the “template” drop down, select “Flash Only - Allow Full Screen.” Your published HTML/SWF will now support full screen mode.

If you are using Flash 8 or Flash MX 2004, you need to edit the player embed code your version of Flash publishes. To do so, publish an HTML/SWF using the default HTML template. Afterward, open the HTML document in a text editor and add the following amongst your `param` elements:

```html
<param name="allowFullScreen" value="true" />
```

Next, add `allowFullScreen="true"` as a new attribute anywhere inside the `embed` element.

That's it! Your HTML/SWF are now supporting full screen mode and the navigation button should function appropriately.
Loading Media RSS feeds

Media RSS is a special flavor of RSS 2.0 created (by Yahoo) to distribute rich media assets like images and videos. Most photo sharing sites like Flickr and SmugMug publish multiple RSS feeds using Media RSS. This walkthrough will show you how to load a feed from Flickr.com.

Note: Not all Media RSS feeds will work in SlideShowPro for Flash. Some sites, even though they offer Media RSS, do not actually publish content in their feeds. Some (like YouTube) merely provide a link to their own player, which will not work in SlideShowPro for Flash.

STEP ONE: COPY MEDIA RSS FEED

Open your browser and visit Flickr.com. If you have a profile, login to your account, then scroll to the bottom of the page. You should see a square, orange RSS feed graphic followed by the words “Subscribe to [yourprofile]’s photos”. Right click on the “Latest” link next to that, and select “Copy Link” (or whatever is applicable to your browser). The URL is now on your clipboard.

STEP TWO: ASSIGN XML FILE PATH

Open Flash, and add an instance of SlideShowPro for Flash to the Stage. Select it, then open the Component Inspector panel. Scroll down to XML File Path and click inside the “images.xml” field. Delete “images.xml,” and paste the URL you copied from Flickr.

STEP THREE: CHANGE XML FILE TYPE

Directly underneath XML File Path is XML File Type. Change this from “Default” to “Media RSS.”

STEP FOUR: PUBLISH

Publish a new movie, and your Flickr RSS content should load.
Loading multiple XML documents

SlideShowPro for Flash allows you to load more than one XML document for your gallery. Each file is loaded, and grouped together as a single gallery of content. You may load XML files you coded by hand, albums/galleries from SlideShowPro Director, or Media RSS feeds. And you can mix different XML file types together. This walkthrough will show you how.

STEP ONE: CREATE AN OPML DOCUMENT

OPML stands for “Outline Processor Markup Language” and is a standard way of bundling one or more XML documents between applications. It’s essentially an XML file that acts as a container for all your XML files. To create one, open your favorite ASCII/HTML text editor, and enter the following:

```xml
<?xml version="1.0"?>
<opml version="1.1">
  <head>
    <title>My gallery</title>
  </head>
  <body>
    <outline type="" xmlUrl="" />
  </body>
</opml>
```

Your single outline node contains two attributes: type and xmlUrl. The latter is an absolute URL to the XML document, while the former dictates the type of XML file the latter contains.

Options for type include “rss”, “xml”, and “director”. “rss” should be used when assigning Media RSS feeds (see previous chapter), “xml” should be used when assigning XML files you’ve manually coded, and “director” should be used when assigning XML File Paths to albums or galleries copied from SlideShowPro Director.

For example, here are outline elements containing a regular XML file, a Media RSS feed from Flickr, and an album from SlideShowPro Director:

```xml
<outline type="rss" xmlUrl="http://api.flickr.com/services/feeds/groups_discuss.gne?id=36521980043@N01&format=rss_200" />
<outline type="xml" xmlUrl="http://mydomain.com/images.xml" />
<outline type="director" xmlUrl="http://mydomain.com/ssp_director/images.php?album=1" />
```

STEP TWO: SAVE THE OPML DOCUMENT

When complete, save your OPML file to the folder where you’re publishing your SWF containing SlideShowPro for Flash. For the purposes of this walkthrough, we’ll name it “opml.xml”.

STEP THREE: ASSIGN OPML DOCUMENT

Open Flash, and add an instance of SlideShowPro for Flash to the Stage. Select it, then open the Component Inspector panel. Scroll down to XML File Path and click inside the “images.xml” field. Delete “images.xml,” and enter “opml.xml” instead. Save the FLA to the folder where your OPML document is.
**STEP FOUR: CHANGE XML FILE TYPE**

Directly underneath XML File Path is XML File Type. Change this from “Default” to “OPML”.

**STEP FOUR: PUBLISH**

Publish a new movie, and after a few seconds all the OPML content should load as one gallery.

---

Note: Because this involves loading/parsing multiple XML documents, try not to assign too many XML files as one gallery. Consider breaking them up into smaller groupings if the speed is too slow.
Updating and troubleshooting
Updating previous versions

Follow these instructions to update your SlideShowPro for Flash extension, as well as any FLA containing an older instance of the component.

INSTALL UPDATE

Unzip the version of SlideShowPro for Flash you downloaded and double click on the .mxp file inside the “Extensions” folder. Extension Manager will launch and ask if you want to update the installed version. Click “Yes to all”. When complete quit Extension Manager.

UPDATE EXISTING FLAS

Now that you have the extension installed, what about existing FLAs with older instances of SlideShowPro in them? Here’s how.

FLASH CS 3

If using Flash CS3, SlideShowPro for Flash comes with a couple of Commands you can use to make this process easy. First, open the FLA containing the older instance of SlideShowPro. Second, select the instance on the Stage, and make sure it has an instance name of “my_ssp” in the Properties panel. Third, select “Commands > SSP - Export Param XML” from application menu. You will be prompted to save an XML file. Save it as “param.xml” to your desktop.

Now select “File > New” and choose “Flash File - ActionScript 2.0.” When the FLA opens, select “Commands > Attach Component.” A new instance of SlideShowPro will be added to the FLA. Next, select “Commands > Import Param XML” and select the XML file you just exported. Click “Okay” and the instance will update with all the parameters (that match) from your older instance.

Note: These scripts will update parameters with names/values that remain valid between versions. So depending on how old your instance is, you may need to manually change some settings thereafter.

You may now use this FLA to publish an updated SWF. Or, if you’d like to move the instance to your older FLA, delete the instance of SlideShowPro from the Stage as well as the Library asset in your older FLA, then copy/paste the new instance over.

FLASH MX 2004 / FLASH 8

Because these older versions of Flash aren’t compatible with the Commands noted above, updating in Flash MX 2004 / Flash 8 isn’t quite as “safe.” Flash allows you to drag a new instance of SlideShowPro from the Components panel to the Stage, and Flash will attempt to update your old instance for you. We have found that this works fine for some users, while with others it can cause instance corruption. If you want to attempt this, backup your older FLA first, then try the aforementioned. If when published everything seems okay, great! If not, you will need to create a new FLA with a new instance of SlideShowPro and manually adjust its parameters to match the instance in your older FLA.
Questions and answers

This chapter contains common questions and troubleshooting requests received from SlideShowPro users. If you can’t find an answer to your question, visit the forums at slideshowpro.net.

EXTENSION MANAGER WON’T INSTALL EXTENSION. WHY?

Quit Extension Manager, launch Flash, and select “Manage Extensions” from the Help menu. Extension Manager will launch and should recognize Flash. Re-try installing the extension.

WHY DOESN’T MY SLIDESHOW CONTENT DISPLAY?

Double-check the structure of your XML document. Make sure that each element in the XML is on its own line (not compacted) and that there is a space between each attribute. Third, check to see if your textual content (“caption,” “title,” “description”) contain any non-ASCII characters like ampersands, or any international characters. These can cause your XML to cause an error when loaded. If you do have international characters, HTML formatting, or special characters, convert them to numerical character entities. A good chart for these may be found here: http://www.fjordaan.uklinux.net/entities/entities_support.html

Next, make sure that your file names assigned in the each “src” element are exactly the same as your actual files. In other words, “image.JPG” is not the same thing as “image.jpg.” Case matters. Also check to make sure your operating system isn’t hiding file extensions. If it is, you may be seeing “image.jpg” but the actual file name is “image.jpg.jpg.” Turn off file extension hiding if possible.

WHY DOES MY SLIDESHOW WORK FINE IN ONE BROWSER, BUT NOT ANOTHER?

Chances are you made some modifications to the param / embed elements in your HTML to embed the SWF that broke cross browser compatibility. The most common mistake made is editing the path to your SWF in one place (like param, for example) but not the other (embed). Both paths to your SWF must be exactly the same.

HOW DO I START A SLIDESHOW WITH THE GALLERY OPEN?

Set the Gallery Appearance parameter in the Component Inspector to “Open at Startup.”

CAN I REMOVE THE NAVIGATION WHEN THE GALLERY IS OPEN?

Yes. Set Navigation Appearance to “Hidden when gallery open.” Your users will be forced into selecting an album after opening the gallery, and will not be able to return to the album currently loaded.

WHY CAN’T I LOAD A SWF CONTAINING SLIDESHOWPRO INTO ANOTHER SWF?

The parent movie loading your SlideShowPro for Flash SWF must be published to a player version and ActionScript setting that supports the component. In your parent FLA, open “Publish Settings” from the File menu, click on the “Flash” tab, and make sure “Version” is set to “Flash Player 7” (or higher) and that “ActionScript Version” is set to “ActionScript 2.0.” SlideShowPro requires these.
settings in order to function.

**MY SLIDESHOW CONTAINS SOUND EFFECTS, BUT THEY DON’T PLAY WHEN LOADED INTO A SEPARATE SWF. WHAT’S UP?**

The sound files embedded in the Library of your SlideShowPro for Flash SWF need to be embedded in the Library of the parent movie that loads the SlideShowPro for Flash SWF. Add them to the parent in the same way, and give them identical linkage IDs as well.

**MY SLIDESHOW SEEMS TO ANIMATE/TRANSITION SLOWLY. WHY?**

Check the frame rate of your FLA. 12fps is the default framerate of new FLAs, which is too low. Open the Properties panel, and change the frame rate of your movie to at least 31fps or higher.

**WHY ARE THE NAVIGATION ICONS BLURRY?**

Check the x/y coordinates of your SlideShowPro for Flash instance on the Stage. These numbers must be set to whole pixel coordinates (no decimals). And while you’re in there, make sure the width and height of the component is also set to whole pixels.

**CAN I USE AN IMAGE AS SLIDESHOWPRO’S BACKGROUND?**

In an indirect way, yes. In your FLA, create a timeline layer that’s lower than SlideShowPro for Flash. Place your content there, and position it underneath the component. Then set Content Area Background Alpha to zero for total transparency, or a value between zero and 100 for partial transparency.

**HOW DO I EMBED THE SWF I PUBLISHED IN A SEPARATE HTML DOCUMENT?**

Check out the *SlideShowPro for Flash Customization Guide* included alongside this document in your software download. It includes a chapter on how to do this.